Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

I've Been Having A Hard Time With Aquarium Lights

Discussion in 'Tropical Discussion' started by barb-e, Jan 2, 2008.

  1. barb-e

    barb-e Member

    Joined:
    Jan 19, 2007
    Messages:
    263
    Likes Received:
    0
    Location:
    Michigan, United States
    Last year I bought a 10 gallon aquarium set and it came with a filter and everything including an all-glass light and hood. It worked for about 8 months before it died out. I emailed the company and they quickly responded. They sent me a new one and guess what. That one stopped working after a day. So I decided...maybe i'll just try a different brand. I went to Petco today and spent 30 dollars on a new one and guess what? This one doesn't work either. I just can't win. I will definitely be taking it back to the store tomorrow. I just want to know from all the other aquarium keepers out there... Is there any aquarium light that works?
     
  2. jarcher1390

    jarcher1390 Member

    Joined:
    Aug 2, 2005
    Messages:
    681
    Likes Received:
    0
    Location:
    uk Cumbria
    what type of light is it
    make
    wattage
    Jonny
     
  3. barb-e

    barb-e Member

    Joined:
    Jan 19, 2007
    Messages:
    263
    Likes Received:
    0
    Location:
    Michigan, United States
    The first one was all-glass and this new one is aquatic gardens. Maybe it's the price that's affecting the quality because I just searched the internet and almost all the other lights I saw were close to or over $100.

    Oh and it's a 15watt.
     
  4. Mikaila31

    Mikaila31 Always Watching

    Joined:
    Aug 29, 2005
    Messages:
    3,290
    Likes Received:
    0
    Location:
    Hudson, Wisconsin USA
    Wow. I have never had any problems with all-glass hoods, I have 5 of the 15watt ones. Three of them are 2 years old and the other two are about 6 years old, they all still work fine. Is it the hood or the bulb that is dying? Was it doing anything funny before it died?

    cheers,
    Mikaila31
     
  5. jasonskillz

    jasonskillz Member

    Joined:
    Jan 15, 2006
    Messages:
    360
    Likes Received:
    0
    Location:
    California, USA
    first thing: dont ever buy something from petco!
    second: dont sacrifice quality for cost.
     
  6. barb-e

    barb-e Member

    Joined:
    Jan 19, 2007
    Messages:
    263
    Likes Received:
    0
    Location:
    Michigan, United States
    I know
    and
    I know


    And maybe All-Glass used to make quality stuff. I actually have one of their heaters and it works fine. But the lights. I think they have a wiring problem. My last one would come on but you'd have to flip the switch back and forth about 15 times...sometimes more.
     
  7. confusion

    confusion Member

    Joined:
    May 29, 2006
    Messages:
    573
    Likes Received:
    0
    Location:
    Atlanta, GA
    what kind of light is it? I have a hood that takes two normal screw-in light bulbs. I threw out the normal incandescent bulbs and put in some CF daylight bulbs from home depot and it works great. If you have the long tube type of light, there's not much you can do but try to return the broken one to petco.
     
  8. chr15_8

    chr15_8 Member

    Joined:
    Sep 10, 2006
    Messages:
    1,445
    Likes Received:
    0
    Location:
    Middlesex
    thats a faulty switch/collapased switch. nothing they can do tbh. they buy loads fit them etc
     
  9. Hollymolly4

    Hollymolly4 Member

    Joined:
    Dec 28, 2007
    Messages:
    175
    Likes Received:
    0
    Location:
    USA
    Could it just be where you're plugging it in? Have a short somewhere? That is strange.
    I've had my lights from my first two tanks for over a year with no problems. I always change the bulb out for one for plants.
     

Share This Page