Slime covering everything

sswiger

New Member
Joined
Jan 12, 2005
Messages
16
Reaction score
0
I have a planted 30 gallon with low light approx. 45 watts. I have been having problems with Algae, the Hair stringy type growing all over the place. Most of my plants are dead or they are covered & not growing I even had a couple fish die. I got some oto's to help but now everything is covered in this clear slime and I don't think it is algae because it is in my filter box as well. My filters are getting clogged to where the water is barely dripping out, I cannot keep them clean I replaced one new set in less than a weeks time. The water intake gets covered also and slows down the water filtration as well (1 time i think it stopped).
My ph has went up over the past months but it is still about 8.2 and the kh is slightly lower than normal. The Amonia has tested 0, nitrites 0, and nitrates around 20.
It is not overstocked I have 3 corys(1 recently died), 4 neons (1 recently died), 2 other tetras, 2 otos, 1 mail betta, and a snail (hitchiked on a plant)
I had droped my partial water changes to monthly because of time.
What is wrong??????? Help me? what is this slime? is it Algae? but it can be if it is in my filter box where there is no light, right?
 

iggy01

Fish Crazy
Joined
May 12, 2004
Messages
381
Reaction score
0
Location
England
To be honest, I have no idea what it is. But , I think your best course of action would be to clean as much of it out as possible and make your water changes much more frequent. Weekly water changes at least.

What do you add to your tank water?

Are you using any pH buffers etc?
 
Top