Help!

Akayers

New Member
Joined
Aug 13, 2022
Messages
4
Reaction score
0
Location
United States
I have a tank that's been up and running, we tested water it was perfect so we bought 3 dalmatian mollies, two snails, and two African dwarf frogs. One by one the all died. I took water in to be test at a reputable store and they said water was fine, do a 20% water change. Did brought back in it was fine so we got a bristlenose pleco. (12 days ago) it seems to have been fine. So we bought 3 more dalmatian mollies. All died within 24 hours. Took they back to the store they tested, I talked with them. No reason they should have died. But we decided to get a different type. So we got fancy guppies. Now my pleco is not doing good. Seems to have lost color (albino) and doesn't move. Water had a slight raise in ammonia but only to .25 but is now back to 0. What am I doing wrong? I don't think I'm over feeding... they eat small amounts twice a day. Water is clear. I use water conditioner, I used an ammonia decreaser to help after the dead fish. I changed the water 30% after the last fish died. I just don't know what to do to save him....

Tank size: 20
tank age: 2 1/2 weeks (used turbo start)
pH:7.5
ammonia:0 (when it spiked it was only .25ppm
nitrite:0
nitrate:0-5ppm (it's not yellow but also not that orange)
kH:
gH:
tank temp:78°
 

Attachments

  • 20220813_215408.jpg
    20220813_215408.jpg
    400.6 KB · Views: 23

Aqua67

Fish Fanatic
Joined
Mar 14, 2022
Messages
141
Reaction score
177
Location
Michigan
Did you use any soap or spray bottle cleaners on your tank when you set it up? Are you using a bucket that has been used for car washing or household cleaning in the past?
 

Slaphppy7

Mod Squaderator
Staff member
Global Moderator ⚒️
Joined
Jan 20, 2021
Messages
7,683
Reaction score
6,543
Location
SE Texas
Welcome to TFF

How long has the tank been set up? Did you cycle the tank before adding fish?

What kind of test kit do you have? What kind of water conditioner?
 
OP
OP
A

Akayers

New Member
Joined
Aug 13, 2022
Messages
4
Reaction score
0
Location
United States
Did you use any soap or spray bottle cleaners on your tank when you set it up? Are you using a bucket that has been used for car washing or household cleaning in the past?
No I haven't used anything around it. When I started it I just used water to wash it out. No soaps. We used the hose to set it up. Put it through a window.
 
OP
OP
A

Akayers

New Member
Joined
Aug 13, 2022
Messages
4
Reaction score
0
Location
United States
Welcome to TFF

How long has the tank been set up? Did you cycle the tank before adding fish?

What kind of test kit do you have? What kind of water conditioner?
2 1/2 weeks but I used turbo start bacteria.
I use a master tester kit and the store tested and got same results.
 

Byron

Supporting Member
Tank of the Month!
Joined
Feb 25, 2009
Messages
19,122
Reaction score
11,026
Location
CA
First, when you have water tests done by a store, or do them yourself, always get the exact number and post that. We've no idea what the store person might think is "fine;" obviously the water here is not fine for some aspect.

Second, the tank does not appear to have been "cycled" in any way. I don't know anything about Turbo Start, it may or may not help but it certainly cannot instantly cycle.

Third, are you using a water conditioner, and if yes which brand? I assume tap water is being used to fill the tank, or is it well water or rainwater?

Do not acquire any more fish until we sort this out. We will, though it will mean lots of questions to do so.
 
OP
OP
A

Akayers

New Member
Joined
Aug 13, 2022
Messages
4
Reaction score
0
Location
United States
First, when you have water tests done by a store, or do them yourself, always get the exact number and post that. We've no idea what the store person might think is "fine;" obviously the water here is not fine for some aspect.

Second, the tank does not appear to have been "cycled" in any way. I don't know anything about Turbo Start, it may or may not help but it certainly cannot instantly cycle.

Third, are you using a water conditioner, and if yes which brand? I assume tap water is being used to fill the tank, or is it well water or rainwater?

Do not acquire any more fish until we sort this out. We will, though it will mean lots of questions to do so.
First, when you have water tests done by a store, or do them yourself, always get the exact number and post that. We've no idea what the store person might think is "fine;" obviously the water here is not fine for some aspect.

Second, the tank does not appear to have been "cycled" in any way. I don't know anything about Turbo Start, it may or may not help but it certainly cannot instantly cycle.

Third, are you using a water conditioner, and if yes which brand? I assume tap water is being used to fill the tank, or is it well water or rainwater?

Do not acquire any more fish until we sort this out. We will, though it will mean lots of questions to do so.
Absolutely everything is listed in the post. All test results.
 

Byron

Supporting Member
Tank of the Month!
Joined
Feb 25, 2009
Messages
19,122
Reaction score
11,026
Location
CA
Absolutely everything is listed in the post. All test results.

Yes, sorry, I missed that. somehow thought the store tests were later, and the numbers in post 1 were initially.

What water conditioner? And what is the "ammonia decreaser" exactly?
 

Kyshiara

Fish Crazy
Joined
Aug 18, 2022
Messages
292
Reaction score
165
Location
UK
I would stop getting new fish. Also, is it 20l or 20g?
 

Most reactions

trending

Top