Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

  1. click here!
    FishForums.net Vote Pet of the Month
    Dismiss Notice

Aquaclear 50 Making A Strange Noise O.o

Discussion in 'Tropical Fish Emergencies' started by Ogrt48, Mar 26, 2006.

  1. Ogrt48

    Ogrt48 Member

    Joined:
    Oct 26, 2005
    Messages:
    346
    Likes Received:
    0
    Location:
    NYC
    Today my Aquaclear 50 has been making a random churning like noise every few minutes. Does this mean its gonna die or just need to be cleaned? If so does this noise mean it needs cleaning in a certain area? Water flow seems fine
     
  2. WILDER

    WILDER Retired Moderator
    Retired Moderator

    Joined:
    Nov 5, 2004
    Messages:
    21,638
    Likes Received:
    10
    Location:
    GB
    I would give the impellor a clean, as it sounds like it grinding which is not good.
     
  3. Ogrt48

    Ogrt48 Member

    Joined:
    Oct 26, 2005
    Messages:
    346
    Likes Received:
    0
    Location:
    NYC
    Thats on the left side under the u tube right?
     
  4. WILDER

    WILDER Retired Moderator
    Retired Moderator

    Joined:
    Nov 5, 2004
    Messages:
    21,638
    Likes Received:
    10
    Location:
    GB
    Sorry don't no never had that type of filter, read the instructions.
     
  5. pokagon55

    pokagon55 Member

    Joined:
    Feb 3, 2006
    Messages:
    149
    Likes Received:
    0
    Location:
    Indianaplois
    I have two Aqua Clear filters. Take the impellar out and clean off the metal part by scrapping it. This metal needs to be cleaned every two to three months. The motor works like a genrator and has a magnetic effect on the impellar, that is what makes it go round.
     
  6. Ogrt48

    Ogrt48 Member

    Joined:
    Oct 26, 2005
    Messages:
    346
    Likes Received:
    0
    Location:
    NYC
    Thanks waterboy. I took the impellar completely apart and scraped all the pieces with a knife, the metal rod inside the part with a plug, couldn't get that out but shoved a knife in scrapping it, and the parts I did get out I scrapped too. The thing is, all the parts looked perfectly fine, nothing on em at all but it worked o.o wtf? It's been back up 2 hours and no grinding noises =)
    Thanks so much
     
  7. Shelly_Otterkin

    Joined:
    Jan 30, 2006
    Messages:
    335
    Likes Received:
    0
    Location:
    Redding CA
    What do you use as your gravel? I use sand and that is the noise I get when a grain of sand gets in it.
     
  8. Ogrt48

    Ogrt48 Member

    Joined:
    Oct 26, 2005
    Messages:
    346
    Likes Received:
    0
    Location:
    NYC
    Sand here but when I opened the entire filter I didn't find any sand, just the green stuff. yucky.
     
  9. WILDER

    WILDER Retired Moderator
    Retired Moderator

    Joined:
    Nov 5, 2004
    Messages:
    21,638
    Likes Received:
    10
    Location:
    GB
    Is it still making a noise.
     
  10. Shelly_Otterkin

    Joined:
    Jan 30, 2006
    Messages:
    335
    Likes Received:
    0
    Location:
    Redding CA
    All it takes is just one small sand. Some times all I have to do is dump the water out of it and it works fine again. How high off the sand bed is your up take? I raised mine and have cut way back on the problem, until the Dojo loach has fun right under it digging again!
     

Share This Page