Jump to content


Photo

Rena Xp3 Not Priming


  • Please log in to reply
2 replies to this topic

#1 karawr

karawr

    Fishaholic

  • Member
  • 472 posts
  • Gender:Female

Posted 16 August 2011 - 12:42 AM

Okay I am HATING filters right now.

I had my rena xp3 on a 75g and to prime it, I'd just push down the little lever on the top of the canister, it would fill itself up, then I'd plug it in and voila.

Now I've moved it to my 90g and it's not priming at all. :angry: I've completely emptied the canister and poured water down the tube. I guess this worked because it's running now but it's also very very loud. Air maybe? But I give it a shake and it doesn't go away.

I can't fill the tube up manually every single time just due to my setup... very difficult to get to the hose. Not only that but my filter would cease to work if the power went out. If I unplug the filter and plug it back in, it won't run. So how do I fix this back to normal?

EDIT: Now it's quieter.... and the outtake seems to be more forceful... guess it pushed all the air out?

Edited by karawr, 16 August 2011 - 01:01 AM.


#2 Plecc

Plecc

    Fish Crazy

  • Member
  • 220 posts
  • Gender:Male

Posted 16 August 2011 - 06:56 PM

Have you checked out the impeller and its housing?
Something catching on the impeller or just gunk in the housing could prevent the filter from restarting.
It could also explain the noise you were hearing!

#3 mattlee

mattlee

    get on a board and do yo thang...!

  • Retired Moderator
  • 7,580 posts
  • Gender:Male

Posted 24 August 2011 - 08:20 PM

if the filter has been removed from the pipes and the pipes emptied of water then the pipes will need re-filling using the funnel if the pipes are empty. if the pipes are still full of water then gravity will do the priming for you.

the noise on these and every filter will be trapped air tilt is side to side and it will go eventually. my FX5's sound like washing machines when first installed due to the trapped air :lol:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users